Power seat isn't working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-17-2007, 00:16   #1 (permalink)
sss
Registered User
 
Join Date: Sep 2005
Posts: 5
Power seat isn't working

I've run into a problem with the power driver's seat in my 2006 Crown Victoria Police Interceptor. The bottom part of the power seat controls work flawlessly, but nothing happens when I try to use the switch that controls how much the seat is reclined. I don't hear any kind of whirring from the motor like I do when I use the controls for the bottom, so this leads me to believe that the motor is shot or that it's simply not getting any power.

Can you guys point me to some basic things that I can check before I take this to a mechanic? Ideally I'd like to do the work myself, even if that means replacing the motor or other work on my part.

Thanks!
sss is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-17-2007, 10:40   #2 (permalink)
Registered User
 
Nathan in MN's Avatar
 
Join Date: Feb 2006
Location: Corcoran, MN
Age: 26
Posts: 283
Re: Power seat isn't working

Do you have a multimeter that you can use for testing? The first thing I'd check is whether the motor is getting power or not. If not, I'd tend to suspect a bad switch.
__________________

1989 Ford Crown Victoria Police Interceptor
2bbl Carbureted 351W V8, ported and polished E7TE heads, Edelbrock cam
AOD Transmission with B&M Shift Kit
3.55:1 Positraction Rear Axle
Visit My Car Domain Account Here Updated 1/27/07!
Nathan in MN is offline   Reply With Quote
Old 09-17-2007, 10:41   #3 (permalink)
sss
Registered User
 
Join Date: Sep 2005
Posts: 5
Re: Power seat isn't working

I should be able to check it out. Do you know how I can access the motor? Do I have to take out the seat, or...?
sss is offline   Reply With Quote
Old 09-17-2007, 17:11   #4 (permalink)
Registered User
 
Nathan in MN's Avatar
 
Join Date: Feb 2006
Location: Corcoran, MN
Age: 26
Posts: 283
Re: Power seat isn't working

Not specifically, no. You may have to take the seat out, but if you can see it down there underneath, you can probably get at it. I'm not too familiar with the newer stuff, so I'm going just on basic electronic troubleshooting skills, here.
__________________

1989 Ford Crown Victoria Police Interceptor
2bbl Carbureted 351W V8, ported and polished E7TE heads, Edelbrock cam
AOD Transmission with B&M Shift Kit
3.55:1 Positraction Rear Axle
Visit My Car Domain Account Here Updated 1/27/07!
Nathan in MN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 16:10.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.