very loud pinging noise, CV1999 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-13-07, 11:23 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 1
very loud pinging noise, CV1999

Hi everyone

I have a Ford Crown Victoria 1999

Have already done 120K miles

Recently I noticed a loud pinging noise coming from the engine ( like when using low grade fuel though I use premium 95 fuel since day one )

The sound comes at any speed between 40-80 miles going up on hills,going down or in a straight road,it comes all the time

I have changed O2 sensors, intake manifold (upper and lower ), temperature sensor, spark plugs , and ignition control box and nothing worked

Have had it in more than 5 shops including ford dealer but without any improvments ( actually no one could figure out the cause of the problem )

If anyone could help me resolving this I would appreciate it!!
valmer is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-14-07, 05:16 AM
Registered User
 
dryelf327's Avatar
 
Join Date: Sep 2006
Location: Houston
Posts: 105
Re: very loud pinging noise, CV1999

Flush cooling system adn replace t-stat. Clean MAF sensor. Seafoam the top end of the motor. BTW, the vehicle calls for 87 octane. I've ran 87 in both of mine with no pinging.

My Fords:
'98 Crown Vic LX
-167k miles and counting. Still used as daily driver.

'99 Crown Vic Police Interceptor
-Completed full PI swap
-Marauder Airbox & 80mm MAF
-'04 CVPI Ziptube
-ADTR ported plenum
-Steeda Intake Spacer
-BOC tune
-J-Mod tranny
dryelf327 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome