Very weird issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-19-2013, 14:51   #1 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 1
Very weird issue

I have a 95 Crown Vic and on the right side the blinker works sometimes and then it doesn't. It actually works all the time but not correctly. It acts as if the bulb is blown causing the flash to blink fast but the bulb is not blown.

What I am thinking it is, is a wire is loose. When the right blinker is turned on the light that comes on on the side works but the bulb doesn't and the rear does a fast blink.

Since I don't have a wiring diagram of this car I was hoping someone could vere me in the right direction on how to fix this. It would mean a lot to us.

Than you in advance!

Grace and Peace to you!
Richard
mrseedsower is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-19-2013, 16:13   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,771
Re: Very weird issue

There are 2 bulbs in on each side the rear and if one is burned out. it'll do that. The multi-function switch can also. You could try spraying WD40 around the hazard button and operate it a few times if the bulbs are all working. Here's access to the repair manual and diagrams. | Repair Guides | Wiring Diagrams | Wiring Diagrams | AutoZone.com
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:54.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.