'98 E150 misfire - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford E-Series Trucks Forum for discussion of the Ford E-Series Trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-07-13, 07:34 PM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 1
'98 E150 misfire

Hello all,
Looking for suggestions regarding 1998 E150 4.2L V6 misfire. Van has 195,000 miles on it. The only code I get, or ever got, and still get, is P0304. So, I replaced the coil pack and the #4 injector. I swapped the plug wire with another one and there was no change. Compression is fine. The engine starts and idles fine, and is fine at highway speed. The misfire only seems to happen when accelerating from a stop, briefly, also when you take your foot off the gas at a good speed and use the engine drag to decelerate, it is the worst when just cruising around local streets at about 35-40 mph, when the engine is at a low RPM and a higher gear.


Thanks!


Last edited by wnspecht; 04-08-13 at 08:29 AM. Reason: Wrong idea.
wnspecht is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-08-13, 10:01 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,311
Re: '98 E150 misfire

Did you check the spark plugs? What brand are they?

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford E-Series Trucks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome