1993 ford probe engine making popping/knocking noise - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Probe Forum | Mazda MX6 Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Probe Forum | Mazda MX6 Forum Forum for discussion of the Ford Probe and Mazda MX6.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-09-2010, 03:09   #1 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 1
confused 1993 ford probe engine making popping/knocking noise

i have a 93 probe gt, 5 speed. when i bought it everything ran great, then about a month later i was driving home from work and the engine started making a loud metallic popping sound, but i drove the rest of the way home just fine, the only issue was it made a lot of noise, still ran and drove fine. i checked it out when i got home and found out the car apparently had an oil leak somewhere because my oil had almost all drained out. i refilled the oil and it still was making the noise. ive also heard that this engine has a bad habit of the lifters getting stuck if the oil gets low, but i dont know if thats true or not. anyone have any ideas i could look into to see if its the problem? im about to start trying to find the problem but at the moment id be blindly diving into it without a clue what i should be looking for. any ideas would be greatly appreciated.
tonyondersma is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2010, 19:43   #2 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 11
Re: 1993 ford probe engine making popping/knocking noise

This kinda sounds like you could have burned up a main bearing. Could be a lifter but most likely a main, you will want to get it fixed pretty quick so that dont spin it on the crank and it mills the crank down.
midnghtshdow is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Probe Forum | Mazda MX6 Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:27.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.