1996 probe 2.0 base stick shift breaking up under acceleration - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Probe Forum | Mazda MX6 Forum Forum for discussion of the Ford Probe and Mazda MX6.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-26-13, 08:14 AM Thread Starter
Registered User
 
Join Date: May 2013
Posts: 1
confused 1996 probe 2.0 base stick shift breaking up under acceleration

This probe is a mini stock race car that races on dirt. We have changed or replaced the spark plugs, plug wires, distributor, egr valve, tps, icv, fuel rail, we cleaned the injectors, and put in a new fuel pump NONE OF THIS HELPED!

The car will sit in my garage and idle perfectly, but as soon as it's put under the load of acceleration, it breaks up and starts spitting and sputtering!

Obviously, this must be an electrical issue - PLEASE HELP!!

maddmatty21 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-26-13, 08:59 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,349
Re: 1996 probe 2.0 base stick shift breaking up under acceleration

Have you checked for codes? Autozone and O'reilys will check for free. Try it with the MAF unplugged after you check for codes otherwise it'll set a code and confuse the issue.

Bert
Bert is offline  
post #3 of 4 (permalink) Old 05-26-13, 10:01 AM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 6,097
Re: 1996 probe 2.0 base stick shift breaking up under acceleration

Did you remove the O2 sensors?

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #4 of 4 (permalink) Old 05-26-13, 10:12 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,172
Re: 1996 probe 2.0 base stick shift breaking up under acceleration

After the distributor work , recheck timing .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Probe Forum | Mazda MX6 Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome