93 Probe Weird Blinker Problems... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Probe Forum | Mazda MX6 Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Probe Forum | Mazda MX6 Forum Forum for discussion of the Ford Probe and Mazda MX6.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-18-2012, 19:06   #1 (permalink)
Registered User
 
Join Date: Apr 2012
Posts: 1
93 Probe Weird Blinker Problems...

I have a 93 Probe SE I just bought for 1300. Everything is good except for the Left Blinker. When I put on the Left Blinker, all the Blinkers(Front and back, left and right) AND the License Plate lights all blink at the same time...
Also, sometimes the Left Blinker indicator will stay lit even when the blinkers are turned off. I checked the bulbs and they all look good, no corrosion or anything...
Anyone ever had any problems like this? Thanks.
Probeasaur is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-19-2012, 07:33   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,704
Re: 93 Probe Weird Blinker Problems...

There's usually a poor ground at one of the lights that cause that. Take one bulb out at a time and see how they work. Follow the wires to where they ground on the body.
__________________
Bert
Bert is offline   Reply With Quote
Old 04-19-2012, 09:01   #3 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,115
Re: 93 Probe Weird Blinker Problems...

^x2
R.S.LOGAN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Probe Forum | Mazda MX6 Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:03.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.