motor swap problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Probe Forum | Mazda MX6 Forum Forum for discussion of the Ford Probe and Mazda MX6.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-04-05, 10:03 AM Thread Starter
Registered User
 
Join Date: Oct 2005
Location: north carolina
Age: 31
Posts: 1
confused motor swap problem

I recently swapped my blown 1994 probe gt with a stock 1993 motor, the car is idling high and dumping a lot of feul, the feul has even entered my oil. MAF sensor is good, Throttle position sensor is good, feul pressure to the rail is good. car idles steady but lacks power. any ideas of what could be wrong, this car still has the 94 ecu, do i need the 93 ecu?

butchern1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-05-05, 05:09 AM
Registered User
 
Join Date: Jul 2005
Posts: 12
Re: motor swap problem

I dont know what it could be, but I have a 93 Ecu I will sell you. But it is for a 5 Speed.
93probegt is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Probe Forum | Mazda MX6 Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome