Damper Problem? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
The Pub For General Discussion

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-11-08, 09:46 PM Thread Starter
Registered User
Join Date: Jun 2008
Posts: 1
Damper Problem?

Hi All. Have A 1972 Cougar 351 Cleveland In My Shop. Replaced Intake And Carb And Was Going To Check Timing Also. Got Car Running But When You Go To Set To Timing Specs The Marks Are Miles Away From Where They Should Be And The Car Dies When You Try To Get It There . Is The Damper Spun On The Rubber ? Could It Be Anything Else? Thanks!
hard candy is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-12-08, 12:03 AM
Join Date: Sep 2006
Location: Arkansas
Posts: 6,615
Re: Damper Problem?

Did you disconnect the vacuum advance and plug it off?

If so I would suspect the harmonic balancer has slipped.

Bring #1 piston to TDC and check mark on balancer.
jwko is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > The Pub
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome