Diode fixed - still a little shudder through gears... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
The Pub For General Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-17-07, 10:37 AM Thread Starter
Registered User
 
Join Date: Jan 2007
Posts: 4
confused Diode fixed - still a little shudder through gears...

All,

I had the diode on the mass air intake fixed and put new shocks and brakes on my 1997 Mercury Cougar - but it's still shivers / brrrrs through acceleration and deacceleration ... any ideas on what causes this? Id it still the air / fuel mix or clogged fuel injectors or what ??? or could it still be oxygen sensors ??? Let me know your thoughts

Thank you
wwwired is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-22-07, 03:37 PM
Registered User
 
Join Date: Feb 2007
Posts: 10
Re: Diode fixed - still a little shudder through gears...

hmmmmz, maybe the decellaration is completely unrelated, try checking out the suspension, and maybe even the brakes on the drive wheels
PeTePyE is offline  
post #3 of 4 (permalink) Old 02-25-07, 06:08 AM Thread Starter
Registered User
 
Join Date: Jan 2007
Posts: 4
Re: Diode fixed - still a little shudder through gears...

DOH!

All it needed was a good transmission flush and for good measure I replaced the serpentine belt as it was old and had some cracks in it. No more brrring and shuddering through gears. Now I just need new shocks inside the front struts and to adjust the brakes so it doesn't pull when braking. It's a lot more cougar like now... Slow and steady
wwwired is offline  
post #4 of 4 (permalink) Old 02-25-07, 02:19 PM
Registered User
 
Join Date: Feb 2007
Posts: 10
Re: Diode fixed - still a little shudder through gears...

pulling when braking is some times caused by a warped disc, just try checking that before you go an buy a new strut for it, dont wanna be spendin money when it needn't be spent...
PeTePyE is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > The Pub


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome