Help!!!!!!!!!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
The Pub For General Discussion

LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-15-03, 10:26 PM
Posts: n/a

im posting this everywhere so you might see this more than once. my 79 351 f150 just went to shit and i cant figure out why. it ran fine and i parked ion the drive way and i went back out like 10 min later anfd it wont fire. it starts to turn over and goesRRRRrrrrRRRRRrrrrRRRR but then shit. just a lil sputter and then nuthin i dont know what the **** happened any1??????????
Sponsored Links
post #2 of 7 (permalink) Old 09-15-03, 10:36 PM
Ford Europe Wannabe
TurboDOHC's Avatar
Join Date: Apr 2001
Location: Good ol' Geelong
Age: 34
Posts: 754
Re: Help!!!!!!!!!!!

pop the bonnent and check all connections. Sounds like battery
TurboDOHC is offline  
post #3 of 7 (permalink) Old 09-15-03, 10:52 PM
Registered User
Join Date: Oct 2002
Posts: 101
mmm - sounds like your battery is dying. Only suggestion is get some hot water and pour it over the battery, the heat will help whats left of the battery give a bit more juice, and might be enough to start it, and get it to a garage.
xageetee is offline  
post #4 of 7 (permalink) Old 09-15-03, 10:54 PM
Posts: n/a
im thinkin i didnt explain the sound right. it doesnt sound like a dead battery i mean it turns over fine but it wont actually start it just like tryin to start it with no gas in the tank but it has half a tank. i duno how to explain that noise.
post #5 of 7 (permalink) Old 09-15-03, 11:01 PM
BA'o'Matic 100% working.
Dellboy999's Avatar
Join Date: May 2003
Location: Victoria
Age: 44
Posts: 3,838
Re: Help!!!!!!!!!!!

Maybe carby flooded, float dropped to bottom, so now overfuels to start.

Well happened to my XF. :-)


I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline  
post #6 of 7 (permalink) Old 09-15-03, 11:36 PM
spaced out
Tripper's Avatar
Join Date: Dec 2002
Age: 40
Posts: 648
Re: Help!!!!!!!!!!!

Dirty plugs ?
stuffed leads ?

I used to have an open mind but my brains kept falling out

Tripper is offline  
post #7 of 7 (permalink) Old 09-16-03, 09:26 PM
laminge's Avatar
Join Date: Feb 2001
Posts: 10,402
Re: Help!!!!!!!!!!!

Water in chambers
laminge is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > The Pub
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome