I finally fixed my defrost. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
The Pub For General Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-04-09, 09:09 PM Thread Starter
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,283
I finally fixed my defrost.

It works now.
Attached Images
File Type: jpg defrost.jpg (28.9 KB, 13 views)

Bert
Bert is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-05-09, 01:49 PM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,691
Re: I finally fixed my defrost.

HAHAHAHA
jwko is offline  
post #3 of 3 (permalink) Old 12-05-09, 02:31 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,737
Re: I finally fixed my defrost.

Ha, ha, who needs a blend door. Fords R&D deppartment should be contacting you soon!! I see some big $$$$ coming your way. (Sad to say, but that looks like something my boss would do)
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > The Pub
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome