1986 ford bronco 2 eddie bauer edition - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Bronco Forum Forum for discussion of the Ford Bronco

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-22-13, 11:34 AM Thread Starter
Registered User
 
Join Date: Jul 2013
Posts: 2
1986 ford bronco 2 eddie bauer edition

when I start my truck up it run great, but after driving it about 30 minute it start to missing like it not getting the gas. I need to know what can I do to fix it, please someone help.
Oh and I cant fine the fuel filter.

cbsrab is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-22-13, 12:54 PM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,863
Re: 1986 ford bronco 2 eddie bauer edition

Welcome to the forum cbsrab. It should be under the vehicle in the area of the drivers floor board at the frame rail. It might have a sheet metal guard covering it. Could very well be the problem.
jwko is offline  
post #3 of 5 (permalink) Old 07-22-13, 01:18 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,150
Re: 1986 ford bronco 2 eddie bauer edition

If still having problems after replacing fuel filter , check exhaust and cat ( if fitted ) for partial blockage .If still not right check plugs and wires .again if fitted on that year / model .
R.S.LOGAN is offline  
post #4 of 5 (permalink) Old 07-22-13, 01:21 PM Thread Starter
Registered User
 
Join Date: Jul 2013
Posts: 2
Re: 1986 ford bronco 2 eddie bauer edition

I'll looked all under that truck and I can fine the filter no place. Tell u what I did fine was another fuel pump and a fuel reserve tank but no fuel filter oh and there is a fuel pump in the gas tank.
cbsrab is offline  
post #5 of 5 (permalink) Old 07-22-13, 01:38 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,150
Re: 1986 ford bronco 2 eddie bauer edition

A lot say the filter is where JWKO states but found this also .

On an '86 and ONLY an '86 EFI (well.. '85 2.3EFI's have it too)
the filter is inside the black cannister. ( Not sure if this applies .)

and

i got an 86 bronco ii 2.9 auto 4x4 and i just replaced mine, the filter is in the black canister, use an oil filter wrench to unscrew if on tight, mine was just hand tight. on my truck it was located about 6 inches behind the transfer case skid plate. Be careful not too over tighten it or you'll bust that cheap little o-ring that seals it up.
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Bronco Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome