engin cutting out when hot and high rpm - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Bronco Forum Forum for discussion of the Ford Bronco

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-05-09, 09:09 PM Thread Starter
Registered User
 
Join Date: May 2009
Posts: 2
engin cutting out when hot and high rpm

i got a 89 ford bron co with a 351 windsor and i have replaced the bot fuel pumps and injectors and the whole ignition system and it is still cutting out at high rpms i have about ave up on it


help me please

jbhunter89 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-05-09, 10:19 PM
Bronco Guru
 
Steve83's Avatar
 
Join Date: Sep 2008
Location: Memphis, TN, USA 38135
Posts: 330
Re: engin cutting out when hot and high rpm

Did you TEST anything before you started throwing part$ at it? I hope you saved the old parts since there's probably nothing wrong with most of them. When did this symptom appear? How long does it have to run, & at what RPM before it 'cuts out'? Does it miss, or totally die? Did you change the coil, ICM, or PIP? Fuel filter? How much fuel pressure does it have? Read this caption & the NEXT few:

http://www.supermotors.net/registry/media/507187
Then read this one:

1983 Ford Bronco TSBs & FSAs (Recalls) for '83-96 Bronco's & F150s picture | SuperMotors.net
Steve83 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Bronco Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome