Just bought a 93 XLT... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Bronco Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Bronco Forum Forum for discussion of the Ford Bronco

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-26-2004, 20:12   #1 (permalink)
SVT fo life beotch!!!!!!!
 
Join Date: Mar 2004
Location: Weymouth, MA
Age: 34
Posts: 3
Just bought a 93 XLT...

Hey, whats up, just bought a 93 XLT the other day, it was a used state trooper K9 vehicle, still painted as a MA state trooper in fact lol, anyways, I cleaned the interior all out today (probably vacuumed up an entire dog with all the hair that was in there), spend more time cleaning up the engine tomorrow. Has a bunch of minor problems, gas gauge doesn't work, oil pressure gauge doesn't work, horn doesn't work, no rear seats, needs a paint job, probably a few other electrical problems I don't know about yet, and also needs a new exhaust. I was wondering if anyone had any suggestions on which exhaust to go with if I went aftermarket? Flowmaster seems the only choice as of now. Also wondering if anyone in here had any ideas or things I might want to check out with the car, being it is used and I have never really driven it. It seemed to drive fine from NH back home here to MA, might need an alignment, but other than that engine sounds fine, exhaust sounds fine as well. Sooooo, yeah, soon as I get it painted (hoping for a cheapo maaco paint job, all black), I'll get some pictures going for you all. Lata!
esoteric781 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-03-2005, 04:30   #2 (permalink)
Bronco Member
 
Join Date: Jun 2001
Age: 38
Posts: 40
Re: Just bought a 93 XLT...

Hmm your gas gauge doesn't work either, guess thats a common problem. I have a 93 xlt and have had a broken gauge for about 5yrs now, every 400 miles I fill it up. If you figure out a relatively easy fix for it post it here... hehe. I've had some electrical probs, like the lights cutting out, but it seems the knob for the headlights and interior lights gets a little dirty and tends to make all the lights cut out.
__________________
93 Bronco XLT 5.0 - Central, NJ
piranicon is offline   Reply With Quote
Old 01-04-2005, 01:58   #3 (permalink)
Too many cars.
 
Clarko's Avatar
 
Join Date: Jan 2005
Location: Woodland Hills, CA
Age: 28
Posts: 10
Re: Just bought a 93 XLT...

That gas gauge problem is VERY common. Just do a search over at and look at how many problems they have with the EFI sender units/fuel pumps.
__________________
The List:
1965 Mustang: Coupe 289 2-V 3-sp toploader 2.80 8" under full restoration
1982 Mustang: Notchback used to be 200 1-V soon to be 302 4-V
1988 Bronco XLT: 302 EFI AOD 13-56 4.56 D44 TTB 8.8"
1996 Explorer XLT: 302 EFI 4R70W 3.73 8.8"
2005 Mustang GT 'Vert as soon as I get off my lazy butt and order it.
Clarko is offline   Reply With Quote
Old 07-21-2005, 18:20   #4 (permalink)
Registered User
 
Join Date: Jul 2005
Posts: 2
Re: Just bought a 93 XLT...

Correct about the sending unit in the tank (It's part of the fuel pump assy). I think it's about 250.00 for the part. If you're gonna drop the tank to replace the unit, may as well replace those body mounts while you're there. You'll never get back in there again, so now's the time if any are questionable. Not really a bad job, done one before. About 2 hours total, taking my time, with 1/8 tank of gas (weight is reduced, much easier on a transmission jack). Be sure to use a brass punch when turning the collar or kaboom! I'm about to drop my tank, cleanup the skid plate, and replace the rear body mounts (I've got a noise that sounds like a bad rear shock but isn't, I suspect a body mount). Bought an entire set of aftermarket body mounts, and I have to drop the tank to replace the rear shackle brackets anyhow (pretty rusty looking).
Good luck

Last edited by jerseydevil; 07-21-2005 at 18:25. Reason: add
jerseydevil is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Bronco Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
hello all, I just bought a auIII and need a lil advice My1stEvaFord Australian Falcons 7 10-11-2004 06:54
93 LX Engine Swap timinbusiness V6 and Hot4 Tech 1 06-16-2004 10:25
fools who bought Mustang Cobras last year svtang FPV & Tickford Forum 16 03-31-2003 21:04
just bought another black 93 pgt 91PGT Ford Probe Forum | Mazda MX6 Forum 9 11-29-2001 11:20

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 12:58.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.