2000 Excursion Speed Control Died !! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Excursion Forum Forum for discussion of the Ford Excursion.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-10-13, 10:01 AM Thread Starter
Registered User
 
Join Date: Jul 2013
Posts: 2
2000 Excursion Speed Control Died !!

My Speed Control quit working about the same time my daylight running lights stopped working or maybe that's just a coincidence ??
When I depress the ON button nothing happens, No Cruise Light, Nothing !!
I tried the Self Diagnostic Test by turning the key on while holding in the OFF button and still Nothing, No Lights , No Flashing Lights, Nothing !!

Can Anyone Please help with any advise, It would be most appreciated
as I drive long distances on interstates and my right leg gets cramped up
from the gas petal all day and all those long miles, THANKS AGAI

wdfogle is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-10-13, 12:57 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,919
Re: 2000 Excursion Speed Control Died !!

There was a recall on that subject with that car , checked fuses also ?

2000-03 Excursion vehicles equipped with speed control: The speed control deactivation switch may overheat and possibly cause a fire. Dealers will install a fused wiring harness into the speed control system free of charge.
R.S.LOGAN is offline  
post #3 of 4 (permalink) Old 07-11-13, 08:48 AM Thread Starter
Registered User
 
Join Date: Jul 2013
Posts: 2
Re: 2000 Excursion Speed Control Died !!

Thank you for that info. on the recall, I will contact my local Ford dealer and get this repair done.
It should help my issue, I hope !!
wdfogle is offline  
post #4 of 4 (permalink) Old 07-11-13, 11:22 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,919
Re: 2000 Excursion Speed Control Died !!

If still having problems get back to board , maybe update update us on result ?
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Excursion Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome