2002 7.3l - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Excursion Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Excursion Forum Forum for discussion of the Ford Excursion.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-16-2008, 12:05   #1 (permalink)
Registered User
 
Join Date: Sep 2008
Posts: 1
2002 7.3l

I have a 2002 excursion 7.3L

When i turn the key on to Acc mode / start the truck none of my accessories will turn on *IE power windows, Radio, cluster guages... BUT after 45/60 seconds everything will work i do hear a relay click and then a chime as if the 2nd ignition kicked on and everything works fine..

i have replaced the instrument cluster, i have replaced the gem pack, ignition switch, and ignition switch electrical peice..

anyone have a idea? its driveing me nuts i can not locate/isolate the issue
undergroundaud is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2008, 15:57   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: 2002 7.3l

Electrical issues are almost always hard to pinpoint even with the proper equipment to help diagnose. Have you owned it for more than a year? The reason I ask is that some newer diesels won't allow any accessories to run without the engine running because in cold weather the glow plugs take a bit of energy to warm up the air intake charge before you can start the engine. Turning to accessory mode (turn the key back towards you) should allow you to run accessories without the delay.
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Excursion Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:13.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.