running board lights problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Excursion Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Excursion Forum Forum for discussion of the Ford Excursion.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-07-2009, 19:16   #1 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 1
running board lights problem

I have a 2003 Excursion and for the last 1-2 years the lights on the running boards and sometimes the cargo light stay on for up to 30 minutes after I turn off the key. Had it checked a couple times and no one can seem to tell me what's wrong or how to fix it. The door ajar light also stays on but not all the time. Anyone have a similiar experience or any remedies? Thanks, Jason
jason r is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2009, 22:39   #2 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 1
Re: running board lights problem

Hi there, not exactly sure if this will apply but I have owned ford diesel trucks since 1992. The 99, 02, 05 all had issues with the door switches. The dealer had to replace at least 2 on each truck. These were all crew cabs and the interior and cargo lights would come on. The door ajar light never did give an indication that there was a problem.

Wiley
Wileygp is offline   Reply With Quote
Old 12-19-2010, 18:04   #3 (permalink)
mesaman
 
Join Date: Dec 2010
Location: southern utah
Posts: 3
Garage
Re: running board lights problem

Hopefully this is a simple problem. How do you replace a bulb in the running board lights? It looks like there is a cover on the front light and can be removed underneath. Is that the place to start?
mesaman is offline   Reply With Quote
Old 01-24-2011, 22:54   #4 (permalink)
Registered User
 
AlwaysFord's Avatar
 
Join Date: Jan 2011
Location: Clarksville, Tn.
Posts: 113
Re: running board lights problem

It has to be the door switch or its circuit. Maybe its not grounding as well anymore? Id check that stuff for sure.
__________________
2001 Ford Expedition Eddie Bauer 4x4 (mine)
2003 Ford Focus SE (the wifey)
AlwaysFord is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Excursion Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:24.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.