01 taurus blows fuse - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-29-09, 08:39 PM Thread Starter
Registered User
 
Join Date: Jun 2009
Posts: 1
01 taurus blows fuse

It's blowing a 40amp when I attempt to start. Connections to the battery and ground look ok. Any thoughts? Ignition switch, starter relay, starter?
telder is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-30-09, 01:27 PM
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 01 taurus blows fuse

Quote:
Originally Posted by telder View Post
It's blowing a 40amp when I attempt to start. Connections to the battery and ground look ok. Any thoughts? Ignition switch, starter relay, starter?



Hello and good day:

I would lean more towards the Starter Solenoid, or a Bad Ground somewhere to the Starter.

Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome