01 Taurus break issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-12-08, 11:08 AM Thread Starter
Registered User
 
Join Date: Aug 2004
Posts: 6
01 Taurus break issue

Just in the past 3 days I have noticed that while driving on the way from work, my breaks seem to be slipping. Well let me rephrase that. It takes 20 minutes to drive to work, it's mostly highway.

The breaks seem to work fine on my way out to the highway, but once I get good and going, what would normally should be a regular stop seems that I have to push the break pedal to the ground. I can also here some squeaking involved and the discs are extremely hot.

Is it time for some new breaks?

mano2k1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-12-08, 11:11 AM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,757
Re: 01 Taurus break issue

Yes, definitely time to get the brake system serviced.
jwko is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome