02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-05-2010, 20:47   #1 (permalink)
Registered User
 
Join Date: Nov 2010
Posts: 4
confused 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

My 02 Taurus was working fine, except the instrument panel backlight died completely after being intermittent for months. I pulled the dash apart (radio out, Trim panels, etc), removed the cluster, cleaned the contacts a bit, tested it again before I put it back together and bingo, cluster lights were good again. While I was in there, I had a bulb that needed attention, so I drove the car with the cluster loosely installed to the parts place, pulled it out, went in to get my bulb, put it back in, and went home to reassemble. Somewhere in there, something went terribly wrong. I'm certain I installed all of the connections properly, ALL that works now is are instrument panel lights, heater, and power seat ! The car still seems to run and shift fine, but here is what now isn't working:
-No Power Windows
-No Power Locks
-No Windshield Wipers
-No Speedometer
-No Radio
-Airbag light blinks initially then stays on
-Hi Beam indicator stays on when the vehicle and lights are off, then works backwards when the lights are actually on (illuminated when low beams are on, off when high are on)
-No Brake lights other than 3rd one in rear window
-No Interior lights
-Theft Indicator is blinking

I haven't found any blown fuses. I have to assume something I did caused this, but the connections all seem fine. Maybe I cooked a control module somewhere by hot plugging the panel ? It's like the whole "accessory" system has lost it's mind.

Any thoughts or suggestions where to start ? I'm good with electrical circuits, but the absence of a wiring diagram or service manual make it a bit of a challenge. Any suggestions or assistance would be greatly appreciated.

Thanks in advance.
crgmfg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-05-2010, 21:03   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,704
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

I'm the same way without a digram. If you go to Autozones website, you can get the diagrams there online. It shows the first itam in the diagrams. Check the left column and find the diagram you want.
| Repair Guides | Adjustable Pedals (2002) | Adjustable Pedals (2002) | AutoZone.com
__________________
Bert
Bert is offline   Reply With Quote
Old 11-05-2010, 21:34   #3 (permalink)
Registered User
 
ROBERTSUNRUS's Avatar
 
Join Date: Sep 2010
Location: Lakewood, Ca.
Posts: 84
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

Hi, I would look to see if you didn't pull loose the connector to the ignition switch; [note: these connectors are also known for melting] Then I would look for a bad ground to the cluster.
__________________
BOB
2000 Navigator 1959 Galaxie 2005 Airstream
ROBERTSUNRUS is offline   Reply With Quote
Old 11-05-2010, 22:07   #4 (permalink)
Registered User
 
Join Date: Nov 2010
Posts: 4
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

Thanks for the reply guys. The diagrams will be VERY helpful, and I'll definitely take a look at the switch. I had to manhandle that area a bit to get the column covers back on. Maybe I dislodged something. Much appreciated.
crgmfg is offline   Reply With Quote
Old 11-06-2010, 07:11   #5 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

Quote:
Originally Posted by crgmfg View Post
My 02 Taurus was working fine, except the instrument panel backlight died completely after being intermittent for months. I pulled the dash apart (radio out, Trim panels, etc), removed the cluster, cleaned the contacts a bit, tested it again before I put it back together and bingo, cluster lights were good again. While I was in there, I had a bulb that needed attention, so I drove the car with the cluster loosely installed to the parts place, pulled it out, went in to get my bulb, put it back in, and went home to reassemble. Somewhere in there, something went terribly wrong. I'm certain I installed all of the connections properly, ALL that works now is are instrument panel lights, heater, and power seat ! The car still seems to run and shift fine, but here is what now isn't working:
-No Power Windows
-No Power Locks
-No Windshield Wipers
-No Speedometer
-No Radio
-Airbag light blinks initially then stays on
-Hi Beam indicator stays on when the vehicle and lights are off, then works backwards when the lights are actually on (illuminated when low beams are on, off when high are on)
-No Brake lights other than 3rd one in rear window
-No Interior lights
-Theft Indicator is blinking

I haven't found any blown fuses. I have to assume something I did caused this, but the connections all seem fine. Maybe I cooked a control module somewhere by hot plugging the panel ? It's like the whole "accessory" system has lost it's mind.

Any thoughts or suggestions where to start ? I'm good with electrical circuits, but the absence of a wiring diagram or service manual make it a bit of a challenge. Any suggestions or assistance would be greatly appreciated.

Thanks in advance.


Hello and good day:

I had something similar happen like this to my 99 Ford Escort...I checked all of the Fuses First..nothing. Then I checked the Battery...nothing...Then I checked the Alternator...I found a corroded, loose connection.

Fixed and repaired the Alt...but was still getting the same problem...I then called a Friend that works at a local Ford Dealership...and was advised that it had something to do with the Security System...and it needed to be reset...we had to reset the PCM because it believe the car was being stolen.

I disconnected the Neg ground from the Battery for 6 min, and then reconnected it...that did the trick!!!

When you check the Alt..make sure you have the proper AMP's being generated.
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Old 11-07-2010, 14:54   #6 (permalink)
Registered User
 
Join Date: Nov 2010
Posts: 4
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

Disconencted the negative lead of the battery for 24 hours. No change there.

Had another thought...I drove the vehicle around for probbably 10 miles or so without the cluster plugged in while I was driving aorund looking for a bulb before I put it back together. The Odometer is of course in the cluster. Any chance that could have wigged the car out and locked out all of the systems somehow ?

I haven't had any time to work on it since my last post, but man...there just wasn't that much to it....a few connectors is all...

........
crgmfg is offline   Reply With Quote
Old 11-07-2010, 15:44   #7 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,704
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

The odometer shouldn't have had anything to do with it. Recheck all the connections and all the fuses.
__________________
Bert
Bert is offline   Reply With Quote
Old 11-07-2010, 19:23   #8 (permalink)
Registered User
 
Join Date: Nov 2010
Posts: 4
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

Bad news and Good news.....

First the bad news.... I'm an IDIOT...

Now for the good news....it is FIXED!!! Everything.

All of your inputs were very helpful. After rethinking it all, double checking all of my connections and wires, and studying the wiring diagrams that you guys had pointed me to, "most" of the things I had a problem with had some relationship to the GEM in the diagrams. I took one last look at the fuses specifically concentrating on the ones related to the GEM and BINGO. I had missed it somehow. The GEM power fuse was blown. I'd never have thought it to have affected EVERYTHING that it did, but that was the case. ALL of the things I listed at the beginning of this thread are now working, and of course my instrument panel lights as well, which are what I originally set out to fix. In hindsight, I suspect it blew while I was driving around with the panels pulled. A previous owner had hacked into the harness under the column to install a stereo I assume. One of the lead "hacks" was not taped and had bare wires exposed. I noticed it and thought I'd just be careful and not bmove it and I'd insulate it when I put it all back together. I did, but I suspect I bumped it and shorted it to ground at somepoint beforehand while driving around or climbing in and out, and as such took out the GEM power fuse. Must have been what happened.

I learned alot along the way, and all of your help and comments were very valuable. Thanks to all of you so very much. I sincerely appreciate it.

crgmfg is offline   Reply With Quote
Old 11-07-2010, 20:25   #9 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,704
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

Glad you got it fixed. You're not the only one that can miss something. Thanks for the update.
__________________
Bert
Bert is offline   Reply With Quote
Old 11-08-2010, 18:46   #10 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 02 Taurus, Locks, Windows, Speedometer, Interior lights etc died after...

good going, and glade to see you found it.
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.