03' Centennial Taurus blinker & flasher issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-18-2012, 13:25   #1 (permalink)
DLR
Registered User
 
Join Date: Nov 2012
Location: Plano, TX
Posts: 2
03' Centennial Taurus blinker & flasher issue

A few days ago my blinkers and flashers stopped working.
The bulbs are good.
We've checked every fuse we could find and none are blown.

Has anyone had this issue? What could it be?

Thanks,

DJ
DLR is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-19-2012, 12:17   #2 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,688
Re: 03' Centennial Taurus blinker & flasher issue

Turn signal relay ? Could also try pushing on / off hazard switch a good few times . Seen a sticking switch causing that before on other models .
R.S.LOGAN is offline   Reply With Quote
Old 11-19-2012, 18:45   #3 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,771
Re: 03' Centennial Taurus blinker & flasher issue

As above, spray WD40 in the area around the hazard button when you operate the hazards and also operate the turn signal lever, no spray there.
__________________
Bert
Bert is offline   Reply With Quote
Old 11-20-2012, 02:24   #4 (permalink)
Registered User
 
Join Date: Jul 2012
Posts: 41
Re: 03' Centennial Taurus blinker & flasher issue

If you try unsticking the hazard button and that doesn’t work, the problem could be with the multifunction switch. Check it and get it replaced if necessary.
Jeff Collision is offline   Reply With Quote
Old 11-20-2012, 11:07   #5 (permalink)
DLR
Registered User
 
Join Date: Nov 2012
Location: Plano, TX
Posts: 2
Here's an update.
I've checked and swapped out the following.
Fuses
Bulbs
Electronic flasher
All lights blink except driver front. Driver rear blinks fast.
Hazards do not work.

Pushed hazard button in and out thirty times. No change.



Sent from my iPhone using AutoGuide.com Free App
DLR is offline   Reply With Quote
Old 11-20-2012, 11:42   #6 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,688
Re: 03' Centennial Taurus blinker & flasher issue

Check driver front is getting power .Rear is flashing fast because front is out .
R.S.LOGAN is offline   Reply With Quote
Old 11-20-2012, 18:39   #7 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,771
Re: 03' Centennial Taurus blinker & flasher issue

Did you spray down around the hazard button?
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.