'03 SES questions (and a link for all Ford error codes) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-25-05, 11:29 PM Thread Starter
Registered User
 
Join Date: Aug 2005
Posts: 1
'03 SES questions (and a link for all Ford error codes)

http://obd-codes.com/trouble_codes/ford/index.php

Might as well get that out early, since I see a lot of posts asking about info just like that.

Hooked up a OBD-II scanner and took my car for a drive. It's been basically knocking whenever you need power before the tranny kicks back and it gets higher RPM, which screams to me that it's lack of fuel.

Normally I noticed between 39-45psi, however, when this noise started, I noticed a drop to about 33psi. I've replaced the fuel filter already, and it got just a tad better. So I figured it'd be the fuel pump and or dirty injectors. Anyone else experience anything like this yet?

TurkeyLiz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome