1993 Taurus Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-29-08, 03:19 PM Thread Starter
Registered User
 
Join Date: Mar 2008
Posts: 1
Question 1993 Taurus Problems

Hi,

I have a 93 Taurus that has been running really rough lately. Mostly all winter I have noticed that it needs to warm up for quite sometime before running. If not given enough time to warm up the car will stall or just run really hard. Lately, even if warmed the car is hesitating when the gas is pushed. It seems like its not responding or taking a long time to respond especially on inclines. The more you push the accelerator the less it responds and when it does it respond car feels like it is stuttering or puttering. I'm not a car girl so I don't want to try to guess myself whats happening but any thoughts or ideas would be lovely! Thanks.

CeMurgo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-29-08, 07:04 PM
NESHO SCT Tuner
 
Join Date: Mar 2003
Location: Illinois
Posts: 703
SHOZ123 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome