1995 Ford Taurus Fan/Overheating problem. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-08-11, 03:27 PM Thread Starter
Registered User
 
Join Date: Aug 2011
Posts: 1
1995 Ford Taurus Fan/Overheating problem.

I have a 1995 Taurus, 3.0 L V6 EFI (not flex fuel).

1st issue: My radiator fan won't turn on by itself. Will turn on with heater or AC going.

I have replaced the temp sending unit, and there was another one I replaced (can't remember its name, but it was mainly for the temp gauge) I am not sure what other steps to take or how to figure out what is causing it to not turn on. I did replace my radiator last august because of overheating issues, I have heard there might be a fan control switch in the radiator. Is that the case? Or what other components can cause my radiator fan to not turn on with ac/heater off?

2nd issue: I am having an issue of my car getting hotter than it normally does but only while on the freeway. Once I get off the freeway, into the city it'll go back down to where it normally is.

I checked my coolant, I did add some a month or so ago, but checked the overflow today and it appears to be fine. I haven't heard any squealing or anything to indicate a possible issue with water pump, but haven't actually looked at it. What steps should I take to attempt to find the resolution for this issue?

Any help would be appreciated

Thanks!

dercas is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-09-11, 03:46 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,815
Re: 1995 Ford Taurus Fan/Overheating problem.

Dont know the set up with that particular car , but on most cars the rad fan wont kick in for overheating until it reaches a certain temp governed by the fan sensor switch and then cuts out again when cooled .That is apart from what you say re.heater or AC operating .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome