1996 Taurus GL squeeking... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-27-07, 07:33 AM Thread Starter
Registered User
andrewbutler88's Avatar
Join Date: Jun 2007
Location: Winnipeg, MB
Age: 27
Posts: 3
Exclamation 1996 Taurus GL squeeking...

Hello everyone!

I just picked up a 1996 Taurus GL Sedan... and of course the week after you get it, you notice things that didn't come up when you first seen the vehicle!

The car is overall in decent shape for it's 10+ years of age... there is a bit of rust here and there, nothing major just surface... and some dings and scratches, and one dent in the rear quarter panel that will most likely come out with ease... but on to the problem!

I noticed a very annoying squeeking when I'm driving, and i checked it out, and it is definatley the belt or pullies or both. I bought some belt dressing and sprayed the belt down with it... first when the car was off, then i let it soak for 3-5 minutes and started it up... it didn't squeek at first, but then later on it did... so i opened up the hood and soaked it down while the car was running... and after a generous coat, it didn't squeek at all...

But this morning, when i started her up to get to work, she was squeeking again... I don't know how much of that stuff i should spray on... or if it's in my best interest to change the belt... which seems like a lot of work... so many pullies and so little room!

If anyone has any advice, please let me know... i hate driving around my new car and having it sound like a big, dying eagle soaring down the road!
andrewbutler88 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-28-07, 08:35 AM
Hi-Tech Redneck
Johnny Mullet's Avatar
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 44
Posts: 1,486
Re: 1996 Taurus GL squeeking...

Remove the belt and turn the idler pulley and the tensioner pulley by hand. Either you have a pulley bearing going bad or the belt just needs replaced. Also see if the tensioner is working.
Johnny Mullet is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome