1998 Mercury Sable, Oil Leak (not the pan) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-28-2008, 08:26   #1 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 1
1998 Mercury Sable, Oil Leak (not the pan)

I have had an oil leak on my 98 sable. Its the 24 DOHC Duratec

I got onder the car and checked the Filter to make sure it was on right, it's good. I checked the drain plug, it's good.

So upon further investigation, I discovered the leak is coming from a half dollar size "Sensor looking thing" above the oil filter. It's in the middle of a piece of tube on the front right side of the car, again, above the oil filter.

My instinct tells me this is the oil pressure sensor/switch (BTW my idiot light (oil pressure light) is blinking all the time) but I was told it would be the oil pump that was bad if it was leaking like this.

The leak has gotten so bad that i had to put in 3-4 quarts a day just to drive to work.

Today something started knocking as I accelerate. I would assume it's the oil pump that is completely dead now....

In looking at my manual, it appears that to replace the oil pump on the DOHC, you must take the engine out. If so, that sucks. any help? advice? something i can try before spending $500+ on a 10 year old car with 144000 miles?

If need be i can try and get some pictures of the leak
Zelladir is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-28-2008, 16:43   #2 (permalink)
Multi-Group Moderator
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 32
Posts: 1,825
Exclamation Re: 1998 Mercury Sable, Oil Leak (not the pan)

Quote:
Originally Posted by Zelladir View Post
I have had an oil leak on my 98 sable. Its the 24 DOHC Duratec

I got onder the car and checked the Filter to make sure it was on right, it's good. I checked the drain plug, it's good.

So upon further investigation, I discovered the leak is coming from a half dollar size "Sensor looking thing" above the oil filter. It's in the middle of a piece of tube on the front right side of the car, again, above the oil filter.

My instinct tells me this is the oil pressure sensor/switch (BTW my idiot light (oil pressure light) is blinking all the time) but I was told it would be the oil pump that was bad if it was leaking like this.

The leak has gotten so bad that i had to put in 3-4 quarts a day just to drive to work.

Today something started knocking as I accelerate. I would assume it's the oil pump that is completely dead now....

In looking at my manual, it appears that to replace the oil pump on the DOHC, you must take the engine out. If so, that sucks. any help? advice? something i can try before spending $500+ on a 10 year old car with 144000 miles?

If need be i can try and get some pictures of the leak
With a blinking oil light and a leak from the oil pressure switch, that's a definate reason to replace the oil pressure switch. It screws into a fiiting on the side of the block. 3-4 quarts a day??? It must be a helluva leak if it looses that much. You better at least start with the pressure switch, make sure it's full and go from there. Low oil will cause knocking noises.
__________________
Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:57.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.