2002 Ford Taurus fails with a "BANG!" - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-03-09, 03:14 PM Thread Starter
Registered User
 
Join Date: Apr 2009
Posts: 1
2002 Ford Taurus fails with a "BANG!"

Hello everyone, I'm wondering if anyone could give any hints as to the cause of the following issue. My mother owns a 2002 Taurs SES, and this morning when she attempted to drive it out of her driveway there was a loud "BANG" from the front left side of the car, and she was then unable to move the car without what was described as a "horrible groaning, grinding noise" from the left front axle. When I came by to investigate I noticed that there were five or six broken pieces of some kind of small greasy plastic part or housing strewn on the ground; for some reason the part apparently decided to violently end its relationship with itself. The only clue as to its identity was that it is white, at one time roughly circular in shape, and one of the pieces has "TOP LH" embossed on it in one spot. Any ideas as to what might have happened would be much appreciated, before I call someone to get the wounded beast towed off to the garage...

EightBitRevo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-07-09, 03:50 PM
Registered User
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 34
Posts: 1,835
cool Re: 2002 Ford Taurus fails with a "BANG!"

Quote:
Originally Posted by EightBitRevo View Post
Hello everyone, I'm wondering if anyone could give any hints as to the cause of the following issue. My mother owns a 2002 Taurs SES, and this morning when she attempted to drive it out of her driveway there was a loud "BANG" from the front left side of the car, and she was then unable to move the car without what was described as a "horrible groaning, grinding noise" from the left front axle. When I came by to investigate I noticed that there were five or six broken pieces of some kind of small greasy plastic part or housing strewn on the ground; for some reason the part apparently decided to violently end its relationship with itself. The only clue as to its identity was that it is white, at one time roughly circular in shape, and one of the pieces has "TOP LH" embossed on it in one spot. Any ideas as to what might have happened would be much appreciated, before I call someone to get the wounded beast towed off to the garage...
Sounds like you've had a front spring shatter, and destroyed the sway bar link. Your particular year didn't have the recall. Look above the tire and see if the spring is broken. DO NOT PUT YOUR HANDS IN THERE!!!

Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome