2003 taurus blower relay something Issue. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-22-09, 04:02 PM Thread Starter
Registered User
 
Join Date: Apr 2009
Posts: 1
2003 taurus blower relay something Issue.

I have an issue with my 03 I just got back from the middle east and my car sat the whole time I was gone. I turned on the heater this morning and all I got was high and to top it off it screamed like no other. Now I know what your thinking its the blower motor, but I changed that out and yes the screaming has stopped and I have a ton of air coming through the vents on high only. but all other settings it just shuts down. HELP please. I looked for the relay if there is one and was unable to find it. Thank you in advance for any help you be able to give.

nevel182 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-23-09, 06:30 PM
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 2003 taurus blower relay something Issue.

Quote:
Originally Posted by nevel182 View Post
I have an issue with my 03 I just got back from the middle east and my car sat the whole time I was gone. I turned on the heater this morning and all I got was high and to top it off it screamed like no other. Now I know what your thinking its the blower motor, but I changed that out and yes the screaming has stopped and I have a ton of air coming through the vents on high only. but all other settings it just shuts down. HELP please. I looked for the relay if there is one and was unable to find it. Thank you in advance for any help you be able to give.
Hmmmm

Hello and good day:

Have you checked the Blower Switch?? I would suggest that you inspect/replace the blower motor resistor . The blower motor resistor is used with the blower motor switch to obtain the different fan speeds. If this resistor is bad, some speeds will work while others will not.

The Resistor is located Pass side under dash. remove the cover, and look for a bunch of wires going to the resistor card which is screwed into the evap/heater box

I have heard of this before....I will P/M some of the Guys (Tbird, Chipset, 360ci) and see what they can say.

Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline  
post #3 of 4 (permalink) Old 04-23-09, 07:25 PM
Registered User
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 34
Posts: 1,835
cool Re: 2003 taurus blower relay something Issue.

Definetely sounds like a resistor block issue. Here's a couple pictures I posted previously.




Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline  
post #4 of 4 (permalink) Old 04-24-09, 08:04 AM
Moderator
 
Join Date: Nov 2008
Posts: 1,137
Re: 2003 taurus blower relay something Issue.

Send it out. There is a TSB on that car for water leaks in the right hand cowl cover that
floods the blower motor. You will replace that motor again after the next rain storm.
chipset is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome