2003 Taurus dying. I hear vacuum leak - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-23-09, 12:31 AM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 4
2003 Taurus dying. I hear vacuum leak

Hi. I have a 2003 Taurus that's not running right. It running poorly and dying at stops. I'm under the hood and hear vacuum leak. It seems to be coming from the plenum but then it stops all of a sudden like the leak is stopped. It almost seems like a door is opening and closing inside the plenum. Does anyone know what this is? No check engine light on. Thanks.

texasgilbert is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-23-09, 07:16 AM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 4
Re: 2003 Taurus dying. I hear vacuum leak

ttt
texasgilbert is offline  
post #3 of 4 (permalink) Old 07-23-09, 07:43 AM
Registered User
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 34
Posts: 1,835
cool Re: 2003 Taurus dying. I hear vacuum leak

Start feeling around, check hoses for cracks, feel around the intake as best as you can. Check the DPFE sensor (EGR pressure sensor) hoses and the sensor itself, it will have two thicker hoses going to it from tubes going towards the exhaust manifold and intake manifold.

Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline  
post #4 of 4 (permalink) Old 07-23-09, 11:20 AM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 4
Re: 2003 Taurus dying. I hear vacuum leak

Thanks. I felt around and the leak stops like I plugged the leak but then starts again. It's like the leak is being plugged and unplugged by itself. I'll keep checking. Thanks.
texasgilbert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome