2004 taurus sel - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-13-07, 03:06 PM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 3
2004 taurus sel

my lane changing signals are not working properly. when i put them on then rotate the wheel all the way and then swing it back they do not tunr off. could this be a big problem down the road. and would it be an easy/ cheap fix

taurusguy1012 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-15-07, 10:03 AM
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: 2004 taurus sel

The only way to repair this is to replace the entire multifunction switch. It's an expensive part, but one you can replace yourself.

I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome