2005 Moisture on Passenger Compartment Floor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-19-2008, 05:21   #1 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 19
2005 Moisture on Passenger Compartment Floor

My 2005 Taurus has moisture on the floor board of the passenger side. A quick search shows the TSB from ford (04-15-3) for the water coming into the cabin filter. However mine is having a different problem.

When the AC runs moisture is dripping of a vent that goes through the firewall in the middle of the passenger side. There is a foam seal / gasket that is damp and drips water onto the carpet and padding. I know one other 05 Taurus owner that is having the same issue.

Are others having this, and if so, what have you done to fix it?
ehaiss is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-19-2008, 12:13   #2 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,994
Re: 2005 Moisture on Passenger Compartment Floor

Sounds like the A/C drain is stopped up.
jwko is offline   Reply With Quote
Old 08-19-2008, 12:22   #3 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 19
Re: 2005 Moisture on Passenger Compartment Floor

JWKO, how would I go about testing and correcting this? I have another friend with the same issue.
ehaiss is offline   Reply With Quote
Old 08-19-2008, 12:57   #4 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,994
Re: 2005 Moisture on Passenger Compartment Floor

Note the drain location in photos below, your air conditioner should drain out of this tube. Check and see if it's stopped up.



jwko is offline   Reply With Quote
Old 08-19-2008, 13:29   #5 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 19
Re: 2005 Moisture on Passenger Compartment Floor

JWKO,

That is definately the tube, but the water appears to be "backfeeding" into the passenger compartment. I will check to make sure it is not plugged. If not, then I will use some type of putty or foam sealant to re-seal the drain.
ehaiss is offline   Reply With Quote
Old 08-19-2008, 13:47   #6 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,994
Re: 2005 Moisture on Passenger Compartment Floor

Quote:
That is definately the tube, but the water appears to be "backfeeding" into the passenger compartment. I will check to make sure it is not plugged. If not, then I will use some type of putty or foam sealant to re-seal the drain.
Make sure you leave this tube open. Next time you are out driving the car with the a/c on check and see if liquid is comming out of this tube. I would almost bet it's stopped up causing a drain back in the floorboard.

Might be a good time to check & replace the cabin air filter also if you havent already. It's located under the cowling as seen in the top of the 1st photo.
jwko is offline   Reply With Quote
Old 08-20-2008, 04:51   #7 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 19
Re: 2005 Moisture on Passenger Compartment Floor

JWKO,

Cabin air filter was replaced last week, as I was adding the rubber "top hat" to the shroud to make sure water wasn't coming in there.

I checked last night, and with the air on, the vent was blowing cold air. In addition, a used a screw driver to check the vent, and could not detect any blockage.

I did notice the foam seal between it and the firewall is soaked on the firewall side. My hunch is that water is coming out the drain, then running back up against the foam seal (especially at speed with the wind blowing) and coming back into the compartment. To stop this, I used some putty on the outside of the vent to help seal the tube to the firewall.

I will run the AC longer to see if water is draining from the vent. My friend with the same problem says his is draining from the tube.
ehaiss is offline   Reply With Quote
Old 08-25-2008, 05:21   #8 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 19
Re: 2005 Moisture on Passenger Compartment Floor

Update: I used an epoxy putty and placed it on the underside of the drain tube JWKO shows, next to the fire wall. This definately fixed the problem. I ran the AC all weekend and had no issues with moisture.

My friend with another 05 Taurus did the same thing, but used silicone caulk (he said it was tough to get it on there), and has eliminated the issue as well.

Problem solved!
ehaiss is offline   Reply With Quote
Old 08-25-2008, 08:58   #9 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 2
Re: 2005 Moisture on Passenger Compartment Floor

My 2004 Taurus SES w/ 24v had same issue. I took it back to the dealer and they said that the AC drain occasionally gets clogged with dirt or in rare instances becomes kinked. You might want to see if the drain tube is cloggged at the tip where the water drains outside. Could have tar or dirt jammed in the tip.
Dave Schlosser is offline   Reply With Quote
Old 08-25-2008, 09:07   #10 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,994
Re: 2005 Moisture on Passenger Compartment Floor

Quote:
Originally Posted by ehaiss View Post
Update: I used an epoxy putty and placed it on the underside of the drain tube JWKO shows, next to the fire wall. This definately fixed the problem. I ran the AC all weekend and had no issues with moisture.

My friend with another 05 Taurus did the same thing, but used silicone caulk (he said it was tough to get it on there), and has eliminated the issue as well.

Problem solved!
Glad you got it fixed
jwko is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.