89 Sable Heater/Blower Problem... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-19-04, 02:22 PM Thread Starter
Registered User
 
Join Date: Feb 2004
Posts: 1
89 Sable Heater/Blower Problem...

My girlfriend's 89 Sable has a problem: The blower for the heater works only on the "high" setting. It blows out very nice, hot air then, but absolutely nothing on any lower settings. Any help or suggestions would be appreciated. Thanks.
bunnybrown is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-06-04, 02:45 PM
***** Idiot....
 
LunaticSVT's Avatar
 
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,560
Re: 89 Sable Heater/Blower Problem...

Sounds like it could be your fan switch. The fan switch is what's right behind the knob you use to adjust the speed with. I'd go to a bone yard to find a replacement off a crash of if you want to pay top dollar go to a dealer. Though Autozone will have a replacement for you.
LunaticSVT is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome