92 Taurus l 3.8 dies when hot - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-22-06, 06:53 PM Thread Starter
Registered User
 
Join Date: Aug 2006
Posts: 1
92 Taurus l 3.8 dies when hot

It has coolant, I replaced the cooling system 'puter over the rad so the electric fan's working, but it craps out when I drive slow after a highway run. Usually it takes a half hour wait to get going again. Today after about 10 short hops, I stuck it in overdrive instead of drive then I was able to get it home. Could it be a fuel pressure prob or a fuel filter thing? When it's cool I have no trouble with it. It's sort of like a bad marriage, I just don't want to let go.l

buzzbomb is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome