93 Taurus heating problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-05-2005, 06:34   #1 (permalink)
Registered User
 
hotrodmerc's Avatar
 
Join Date: Dec 2005
Posts: 11
93 Taurus heating problems

HI all 93 Taurus with a 3.8 . It is running hot the fan works and a new thermostat was just put in. It seems as though nothing is flowing through the top rad. hose. The car also has no heat it blows cold air. It is not losing any coolant. The cooling system may be plugged, I don't know? Any ideas???
hotrodmerc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-05-2005, 17:03   #2 (permalink)
Registered User
 
Join Date: Sep 2005
Posts: 38
Re: 93 Taurus heating problems

Was the thermostat installed backwards?
Gary1234 is offline   Reply With Quote
Old 12-05-2005, 19:41   #3 (permalink)
Registered User
 
Join Date: May 2005
Posts: 41
Re: 93 Taurus heating problems

taurus guy is offline   Reply With Quote
Old 12-05-2005, 22:19   #4 (permalink)
Registered User
 
hotrodmerc's Avatar
 
Join Date: Dec 2005
Posts: 11
Re: 93 Taurus heating problems

It was in correctly. I'm thinking head gasket???
hotrodmerc is offline   Reply With Quote
Old 12-06-2005, 09:03   #5 (permalink)
Registered User
 
bertha66's Avatar
 
Join Date: Sep 2005
Location: Central Oregon
Age: 60
Posts: 198
Re: 93 Taurus heating problems

Check the Water pump. Did anything change sence the thremostat change? When you get no heat fromm the heater and the engine is hot usually there is no water in the heater core. make sure that you get the air out of the rad. Are you sure that the engine is hot, gauge may not be working.
bertha66 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.