93 Taurus SHO engine gettin hot - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-07-2006, 14:51   #1 (permalink)
Registered User
 
Join Date: Aug 2006
Posts: 4
Exclamation 93 Taurus SHO engine gettin hot

ok sorry but this is my first car, and im not too good with the whole fixing cars thing. the engine was from another SHO that someone else put in 50000 miles ago and since i bought it i noticed the engine gets real hot n makes my check engine light come on. i figured it was low on anti freeze so i bought some 50/50 n put some in and still same problem. now if i could get some generalization as to what might be the causes that would be awesome. the car also had about 120000 miles on it and its an auto any suggestions can help thanks
phoenixsmash13 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-07-2006, 14:56   #2 (permalink)
Registered User
 
bertha66's Avatar
 
Join Date: Sep 2005
Location: Central Oregon
Age: 60
Posts: 198
Re: 93 Taurus SHO engine gettin hot

When was the last time the thermastat was changed? The water pump may be failing, or the radiator is pluged. Thermastat is were I would start.
bertha66 is offline   Reply With Quote
Old 08-07-2006, 16:42   #3 (permalink)
Registered User
 
Join Date: Aug 2006
Posts: 4
Re: 93 Taurus SHO engine gettin hot

cool we just bought a thermostat for it were gonna install it tommorrow cause its late now and the engine is still kinda hot dont wanna get burned lol ill let you know how it goes thanks
phoenixsmash13 is offline   Reply With Quote
Old 08-08-2006, 17:13   #4 (permalink)
Registered User
 
Join Date: Aug 2006
Posts: 4
Re: 93 Taurus SHO engine gettin hot

alright we replaced the thermostat but its still overheating but we think we might have found the problem....my friend said that when he looked under my hood the fans werent turning? is that a problem? would it cause overheating and why? we also noticed there was a plug that wasnt plugged to anything and we couldnt find where it went to. any help would be great online diagrams or just a simple picture would be awesome
phoenixsmash13 is offline   Reply With Quote
Old 08-08-2006, 20:33   #5 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 3
Re: 93 Taurus SHO engine gettin hot

ya that could be the problem. The larger SHO engines more require more air to cool than the 3.0, so if there's a shortage it could be a problem. How many of the fans are running and how many arn't?

Where exactly is this unknown plug located? Do you know what it belongs to? Do you know where it's supposed to plug into?

If that unknown plug dosn't turn on the fan, it could be a blown relay or something. Talk to your dealer mechanic about getting it fized.
crazyates is offline   Reply With Quote
Old 08-09-2006, 19:46   #6 (permalink)
Registered User
 
Join Date: Aug 2006
Posts: 4
Re: 93 Taurus SHO engine gettin hot

i have a 3.2 in my car we checked it today and the two that are in front of the radiator arent spinning the plug is low between the radiator and i think the engine its hard to get to obviously dont know where it belongs or what its supposed to plug into. i spoke to a gentleman who worked for ford for almost 15 years he said being that the car wasnt drivin that much the past 2 years (the past owner drove it 1-3 times a month for 2 years he only put on about 10k miles in 3 years maybe more) the radiator might be clogged i filled the radiator with antifreeze and when i checked it, the lvl was still the same.....we just changed the thermostat im hoping its clogged ill update later. it sucks when the only place u can work on ur car is in a parking lot u cant do too much all the time
phoenixsmash13 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:14.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.