94 sho wont start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 07-28-11, 12:37 PM Thread Starter
Registered User
 
Join Date: Jul 2011
Posts: 5
94 sho wont start

I have a 94 taurus sho. It started fine this morning but the radio would not work. It said call on it and i believe it had something to do with the old carphone that was installed. I turned the car off in hopes to reset the radio but then it would not start again. When i turn the key forward i get a lot of static through the speakers and the engine wont turn over at all. The theft light on the dash also blinks when i turn the key forward and i can hear clicking coming from the dash. I have no idea whats goin on so any help would be appreciated thank you

Nbarns is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 07-28-11, 08:30 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,300
Re: 94 sho wont start

Have you tried a jump start?

Bert
Bert is offline  
post #3 of 10 (permalink) Old 07-29-11, 09:50 AM Thread Starter
Registered User
 
Join Date: Jul 2011
Posts: 5
Re: 94 sho wont start

No I havent. I will try later today. The car starting acting even crazier now however. When i try to lock the doors they just keep locking real fast until i stick the key in. When i push the horn, theres no sound but the doors lock and i can hear a very fast clicking from inside the dash. I also heard a growling from inside the dash when i trie rolling my windows up. No shit it kinda scared me.. It really sounded like a tiger or lion was inside my dashboard.
Nbarns is offline  
post #4 of 10 (permalink) Old 07-29-11, 01:29 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 94 sho wont start

I would check battery condition and check connections pos and neg
thefonz is offline  
post #5 of 10 (permalink) Old 07-29-11, 01:50 PM Thread Starter
Registered User
 
Join Date: Jul 2011
Posts: 5
Re: 94 sho wont start

Would a low battery or bad connects really cause all those weird symptoms?
Nbarns is offline  
post #6 of 10 (permalink) Old 07-29-11, 03:23 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 94 sho wont start

definitely possible and it costs you nothing to check
thefonz is offline  
post #7 of 10 (permalink) Old 07-29-11, 03:46 PM Thread Starter
Registered User
 
Join Date: Jul 2011
Posts: 5
Re: 94 sho wont start

Ok, thank you very much. I will let you know results of jump start.
Nbarns is offline  
post #8 of 10 (permalink) Old 07-30-11, 07:43 PM Thread Starter
Registered User
 
Join Date: Jul 2011
Posts: 5
Re: 94 sho wont start

I cleaned off the contacts very good, and jumped it and its running fine. Thank-you guys
Nbarns is offline  
post #9 of 10 (permalink) Old 07-30-11, 09:23 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,300
Re: 94 sho wont start

Great news. Thanks for the update.

Bert
Bert is offline  
post #10 of 10 (permalink) Old 07-30-11, 10:57 PM
Registered User
 
AlwaysFord's Avatar
 
Join Date: Jan 2011
Location: Clarksville, Tn.
Posts: 113
Re: 94 sho wont start

I really dont think thats the end of your problems on that one though.

2001 Ford Expedition Eddie Bauer 4x4 (mine)
2003 Ford Focus SE (the wifey)
AlwaysFord is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome