95 SHO 3.2L Fuel Pump Relay - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-12-2006, 14:51   #1 (permalink)
Registered User
 
Join Date: Feb 2006
Posts: 2
95 SHO 3.2L Fuel Pump Relay

I'm wondering if anyone knows the location of the fuel pump relay in a 95 Taurus SHO 3.2L...

I am having trouble with the car starting... When I try and start it, it cranks for a long time, and then it sputters and finally starts. Sometimes it will crank for a long time and not start at all. I'll have to stop cranking it for a couple seconds and try to start it again a second time. But it always fires right up the second time I try to start it. It started doing this after I changed the fuel filter a couple months ago. I thought either the check valve in the fuel filter was bad, or I had a bad connection which was letting air into the fuel line. Well yesterday I took off the cheap fuel filter I originally installed, and installed a Motorcraft fuel filter. Still the same problem. A buddy of mine said he thought it might have been the fuel pump relay going bad. The relay that purges the fuel pump when you turn the key on. I can't find where it's located. My Haynes book doesn't show me where it's at, and neither does my owners manual.

If someone knows where it's at, please let me know. Or if anyone else has any suggestions as to what my problem might be, also please let me know. Thanks to all in advance.
lpdub is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2006, 09:34   #2 (permalink)
Multi-Group Moderator
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 32
Posts: 1,825
cool Re: 95 SHO 3.2L Fuel Pump Relay

It is part of the Constant Control Relay Module, or CCRM, which is located on the center of the radiator support under the shield with the warning labels on it.
tbird100636 is offline   Reply With Quote
Old 02-14-2006, 12:41   #3 (permalink)
Registered User
 
bertha66's Avatar
 
Join Date: Sep 2005
Location: Central Oregon
Age: 59
Posts: 198
Re: 95 SHO 3.2L Fuel Pump Relay

Have you change the fuel pump? Sounds like the pump is getting weak. My 93 did the same until I changed it. I had the feul pressure checked at the last 60k tune up and the machanic said the pressure was low and to drive it until it got hard to start and then change it. When my relay went out, the car would run, but would start only after it sat for a few hours. That went on for about a week and then died. Right now I have the car wired around the relay and without it I have to crank it 2 times in the morning, but otherwise it works fine.
bertha66 is offline   Reply With Quote
Old 02-15-2006, 14:44   #4 (permalink)
Registered User
 
Join Date: Feb 2006
Posts: 2
Re: 95 SHO 3.2L Fuel Pump Relay

I will have to test the fuel pressure again... I tested it right before I started having this problem, and it actually read about a pound higher than the Haynes book recommended. I am starting to think it's not the fuel pump relay anymore. Ever since I posted that first post, I've been paying attention to the pump when I turn the ignition switch on, and it sounds like it purges everytime. I will test the fuel pressure and get back to you guys. Thanks for all the help.
lpdub is offline   Reply With Quote
Old 02-18-2006, 19:40   #5 (permalink)
NESHO SCT Tuner
 
Join Date: Mar 2003
Location: Illinois
Posts: 703
Re: 95 SHO 3.2L Fuel Pump Relay

You can force the fuel pump relay on by grounding the fuel pump test connector on the data plug with the key in run.

SHOZ123 is offline   Reply With Quote
Old 04-04-2006, 08:27   #6 (permalink)
Registered User
 
SHOWME's Avatar
 
Join Date: Apr 2006
Location: Howell, MI
Posts: 1
Re: 95 SHO 3.2L Fuel Pump Relay

Quote:
Originally Posted by tbird100636
It is part of the Constant Control Relay Module, or CCRM, which is located on the center of the radiator support under the shield with the warning labels on it.
So this is the only relay for the fuel pump? It does the 1-2 second purge and pump while engine is starting or running?

I'm having the same problem. I just changed the pump again and it wouldn't start after my wife drove it to the store and tried to restart 10 minutes later. If I wait long enough it starts again fine and usually goes until you shut it off. It's like the relay malfunctions when hot (next to radiator).
SHOWME is offline   Reply With Quote
Old 04-04-2006, 09:38   #7 (permalink)
Registered User
 
bertha66's Avatar
 
Join Date: Sep 2005
Location: Central Oregon
Age: 59
Posts: 198
Re: 95 SHO 3.2L Fuel Pump Relay

Quote:
Originally Posted by SHOWME
So this is the only relay for the fuel pump? It does the 1-2 second purge and pump while engine is starting or running?

I'm having the same problem. I just changed the pump again and it wouldn't start after my wife drove it to the store and tried to restart 10 minutes later. If I wait long enough it starts again fine and usually goes until you shut it off. It's like the relay malfunctions when hot (next to radiator).
My 93 was doing the same until it just stopped running 10 miles from nowhere. The relay box was $150, so I wired around the relay to get it running. I did talk to the Ford garage and they said that there was no problem in the way I had did the wiring, but I do not get the 1-2 second purge when I start the car, so sometimes it will crank for a couple of seconds before it starts, But it has been wired like this now for more than a year and is working fine.
bertha66 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:12.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.