97 Sable Multifunction Switch Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-29-05, 02:01 PM Thread Starter
Registered User
 
Join Date: Dec 2005
Posts: 1
cool 97 Sable Multifunction Switch Problem

My daughter has a 97 sable with several issues. Her wipers quit a month or so ago. We have had no rain in Oklahoma recently so she didn't mention it. Then a couple of days ago, she told me her turn signals had stopped working. I asked her if the emergency flashers worked and the answer was no. They haven't worked since she got the car two years ago. I'm thinking multifuncion sw since all those things go through that switch, at least power. I found a several comments on the multifuction sw on this forum that related to some of her problems. Opinions? I'm going to go over and look at her car this coming weekend. I'll check power but she says the fuses are ok.

Thanks in advance.

speedbumpone is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-13-06, 09:10 PM
NESHO SCT Tuner
 
Join Date: Mar 2003
Location: Illinois
Posts: 703
Re: 97 Sable Multifunction Switch Problem

THE MFS is all gummed up. You can take it off and spray it down in all the oenings with WD 40 and work the switch, repeat, repeat, repeat. Then is should work again.
SHOZ123 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome