99 Taurus Electrical/Heat switch problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-29-07, 11:59 AM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 1
99 Taurus Electrical/Heat switch problem

I am new here, and need help with my 99 Taurus. While driving I heard a strange pop sound followed by an odd burnt smell. Basically what now happens is when ever I put on either the front defrost, or the heat through the floor and the dash vents, my a/c compressor clicks on and off over and over again.

I have done some research and have found people with allot of electrical problems but I haven't been able to find this one. Any suggestions or advice would be most helpfull. thanks in Advance

Will

Dark Poet is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome