Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 11-02-02, 04:00 PM
Posts: n/a
Question Any Ideas

My buddy has a 1989 Tauraus with a 3.8 litre. It has no spark and no fuel delivery. Could a bad TFI module on the side of the distributor cause this?

Thanks, Mike
post #2 of (permalink) Old 11-24-02, 10:42 PM
Posts: n/a
Sorry i just became a member. I have heard that it could. But also make sure that the relays and things of such are still connected.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
FORD AT 100: 5 ideas shaped industrial America Stacy94PGT Ford Worldwide News 1 05-29-03 05:44 PM
Ford tests green waters, farm-based ideas with Model U concept Stacy94PGT Ford Worldwide News 0 02-27-03 09:52 AM
Future Meets/Get Togethers ideas for SA Members MightyEFGhia On the Road in Australia 14 12-23-02 01:20 AM
New Ideas s-code Ford Mustang Forum 0 11-13-01 09:04 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome