Brake lights not working (Taurus 2001) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-10-10, 05:59 PM Thread Starter
Registered User
 
Join Date: Sep 2010
Posts: 1
Brake lights not working (Taurus 2001)

I noticed that my brakes lights were not working .

I checked and replaced fuse number 17 in the fuse boxed located by the brake pedal. The fused looked good but I replaced it anyways.

That did not fix the problem.

I thought it could be the bulbs, so I replaced them too but that did not fix the problem either.

I bought the brake light switch and and I am planning on replacing it. Hopefully that takes care of the problem.If not, do you have any suggestions as to what could be causing the problem?

Thank you in advance for your replies.

Al


Last edited by handy_al28; 09-10-10 at 06:03 PM. Reason: spelling
handy_al28 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-10-10, 06:30 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,346
Re: Brake lights not working (Taurus 2001)

The switch is usually the problem.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome