Brake lights not working (Taurus 2001) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-10-2010, 16:59   #1 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 1
Brake lights not working (Taurus 2001)

I noticed that my brakes lights were not working .

I checked and replaced fuse number 17 in the fuse boxed located by the brake pedal. The fused looked good but I replaced it anyways.

That did not fix the problem.

I thought it could be the bulbs, so I replaced them too but that did not fix the problem either.

I bought the brake light switch and and I am planning on replacing it. Hopefully that takes care of the problem.If not, do you have any suggestions as to what could be causing the problem?

Thank you in advance for your replies.

Al

Last edited by handy_al28; 09-10-2010 at 17:03. Reason: spelling
handy_al28 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-10-2010, 17:30   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: Brake lights not working (Taurus 2001)

The switch is usually the problem.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:56.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.