Brakes acting funny - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-18-2009, 10:34   #1 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 39
Brakes acting funny

Ok so heres the deal,

My brakes where acting fine until the other day when I was pulling fuses looking for blown fuse. No they are acting in a way that I can only describe as loud. They still seem to work ok but may be a little sluggish. The sound is like the brake "motors" are having a hard time working.

my question is, did my checking fuses somehow cuase this, or is it chance that it started right after I started pulling fuses?

oh, 2000 sable dohc
eckstei4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2009, 14:53   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,725
Re: Brakes acting funny

Pulling fuse shouldn't cause anything like that. Does it sound like the ABS is actuating? Hard to tell without hearing it first hand. Being a safety item, I'd have it checked right away. Could have picked up something on the raod that's causing it and it's minor.
Bert is offline   Reply With Quote
Old 10-18-2009, 15:59   #3 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 39
Re: Brakes acting funny

What would abs problem sound like?

after driving today I am thinking that my left rotor is bad. I looked at it today and the inside spaces are pretty rusted, plus I have the tell-tale thumping in my brake pedal. I am guessing that the timing of this and pulling my fuses is just coincidental.

I will have to tear it apart tomorrow if the weater is decent.
eckstei4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:23.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.