code p0401 and p1504 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-04-2006, 06:29   #1 (permalink)
Registered User
 
Join Date: Nov 2006
Posts: 7
code p0401 and p1504

hello, my mom's 99 taurus se 3.0 ohv has a code p0401 and p1504 in the system. book that came with this cheap obd2 reader says that p0401 is egr insufficient flow detected. i am not a mechanic-i was going to take a vacum pump home tonight to test the egr valve. am i wasting my time? the book states there is a backpressure sensor, etc. but i thought that i read something in here about these cars having egr valve problems. book also says p1504 is a dealership code that i can not find in the book i have . please help!!!!
p.s car starts bad when is is cold-i'm hoping it is related to this egr code.
rodfoster is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-04-2006, 13:43   #2 (permalink)
Registered User
 
Join Date: May 2004
Posts: 109
Re: code p0401 and p1504

Yes, tackle the P0401 first as the other code might be a cascade.

I'm not sure how you test the EGR for adequate flow, unless it is clearly plugged.

Don't forget to check the EGR Sensor (aka DPFE sensor). That is a very common failure point. It should be co-located with the EGR Valve. Check the hose and electrical connector.

I recently went through this with my '97 and replaced the EGR valve first, but the code came back. Then I replaced the sensor, and that did the trick.

If the car has over 100K on it, it might be best to replace both.
dac122 is offline   Reply With Quote
Old 12-05-2006, 04:13   #3 (permalink)
Registered User
 
Join Date: Nov 2006
Posts: 7
Re: code p0401 and p1504

thanks for the reply.i picked up a vacum pump and i will check to see if it holds vacum
rodfoster is offline   Reply With Quote
Old 12-05-2006, 11:50   #4 (permalink)
NESHO SCT Tuner
 
Join Date: Mar 2003
Location: Illinois
Posts: 703
Re: code p0401 and p1504

More than likely the P401 problem is the DPF EGR sensor located on back of the intake manifold. It measures the EGR flow and is always a problem with Ford.

The P1504 is the IAC. You can test the IAC by disconnecting the electrical connector on it when the engine is warm and idling. The car should stall.

P1504 - Idle Air Control (IAC) Circuit Malfunction This DTC is set when the PCM detects an electrical load failure on the IAC output circuit.

IAC circuit open
VPWR to IAC solenoid open
IAC circuit short to PWR
IAC circuit short to GND
Damaged IAC valve
Damaged PCM
IAC valve stuck open
Vacuum leaks
Failed EVAP system
Damaged PCM
The IAC solenoid resistance is from 6 to 13 ohms.
SHOZ123 is offline   Reply With Quote
Old 12-06-2006, 08:23   #5 (permalink)
Registered User
 
Join Date: Nov 2006
Posts: 7
Re: code p0401 and p1504

thanks for the reply-one other thing to ask-i actually plugged the reader onto the car for the airbag light on, the engine light wasn't even on-and it gave me these two codes for engine-emissions.i used to work at a gm dealer and the guys there used to tell me (if the light isn't on now-don't worry about it!) but i'm not sure just how good a rule of thumb that is. i guess maybe they are old fault codes and are still in it. i wonder if i should erase the codes and see if they come back.
rodfoster is offline   Reply With Quote
Old 12-06-2006, 08:37   #6 (permalink)
NESHO SCT Tuner
 
Join Date: Mar 2003
Location: Illinois
Posts: 703
Re: code p0401 and p1504

Disconnect the battery to clear the codes and drive around for a couple of days. If the codes come back the you should look into them.
SHOZ123 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:12.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.