Cruise Control Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-03-07, 01:45 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 4
Exclamation Cruise Control Problem

My daughter's 2002 Taurus has a problem with the cruise control. It does not activate. Not a fuse issue. When you set the cruise, the light comes on but immediately goes out again. It may be a switch on the brake pedal (the upper switch on the pedal I'm thinking). Anyone else have this problem and how did you fix it?
asipes is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-07-07, 09:43 PM
Registered User
 
Join Date: Aug 2007
Posts: 1
Re: Cruise Control Problem

I have the same problem with a 99 Taurus. Have no idea what's causing it.
WEIT48 is offline  
post #3 of 3 (permalink) Old 08-08-07, 08:08 AM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 4
Re: Cruise Control Problem

The problem that you are having is a bad speed control switch, located on and attached to the brake pedal. If you look under the dash at the brake pedal, two switches are connected to it. The speed control switch is the one highest up on the pedal. Disconnect the electrical connection and then twist the switch to the right and then pull back to remove. (You should also disconnect the negative battery cable before doing any electrical). Buy a new switch (mine was $27) and reconnect everything in reverse of the disassembly. This takes care of it. Also, Ford just recalled most vehicles for cruise control fire issues.
asipes is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome