diagnostic help please...'93 sable 3.8 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-20-06, 10:20 PM Thread Starter
Registered User
 
Join Date: Mar 2006
Posts: 25
diagnostic help please...'93 sable 3.8

Hi - Any help is appreciated. I have a

1993 sable 3.8
It runs fine (no noticeable problem) except that the check engine light goes on occassionally. I pulled the codes for KOEO and they are:

Current Code - 335: EGR sensor circuit voltage higher or lower than expected

Memory Codes - 57: neutral pressure switch circuit fault; 332: Insufficient EGR flow

For about a year now, the lamp would go on if I went down hill for a few minutes, but would then go out once I was climbing or on flat ground. I didn't notice any problems besides that, and it was so infrequent, that I ignored it. The light goes on and off daily now.

Do you think this might be a bad EGR valve or...?

(Funny thing is that it just passed smog (CA) no problem!)

Thx!

gwald is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-21-06, 06:52 AM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: diagnostic help please...'93 sable 3.8

Those codes are for the DPFE sensor. Also check the hoses that go to the sensor and that should fix it.
Johnny Mullet is offline  
post #3 of 5 (permalink) Old 06-21-06, 10:16 AM
Gearheadus Maximus
 
450HP's Avatar
 
Join Date: May 2006
Location: Omaha NE
Age: 50
Posts: 18
Re: diagnostic help please...'93 sable 3.8

Would a 91 Sable (3.8L) have a DPFE sensor as well?

For the last two weeks, my car has a "stumble" that feels like either fuel cutting out
or the tranny slipping...

The engine and tranny have only 15K miles on them after rebuilds.

The problem only occurs on my return trip home from work... it'll do it once right after I leave work
and then just before I get home.

It's never done it on the way to work...

A friend of mine here at work mentioned that he had an Escort that had a similar problem. He tried
a test pipe in place of the CAT and he stated that fixed the problem.

He claimed that the car would stumble at the same places on the way home, but never on the way to work.

This is what my car is doing...

One more symptom is that the problem happens when I've let off of the gas pedal and I go to step back
down on it.

It will do a few "stumbles" or "hesitations", kind of like a jerky cut-out then it will be fine again.

Anyone have any ideas?

Thanks!
Scott
450HP is offline  
post #4 of 5 (permalink) Old 06-21-06, 05:42 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: diagnostic help please...'93 sable 3.8

Could be a lot of issues there. TP sensor, fuel pump, fuel filter. Is the check engine light on? A DPFE will not cause any driveablility issues.
Johnny Mullet is offline  
post #5 of 5 (permalink) Old 06-28-06, 09:38 AM
Registered User
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 34
Posts: 1,835
Exclamation Re: diagnostic help please...'93 sable 3.8

Quote:
Originally Posted by 450HP
Would a 91 Sable (3.8L) have a DPFE sensor as well?

For the last two weeks, my car has a "stumble" that feels like either fuel cutting out
or the tranny slipping...

The engine and tranny have only 15K miles on them after rebuilds.

The problem only occurs on my return trip home from work... it'll do it once right after I leave work
and then just before I get home.

It's never done it on the way to work...

A friend of mine here at work mentioned that he had an Escort that had a similar problem. He tried
a test pipe in place of the CAT and he stated that fixed the problem.

He claimed that the car would stumble at the same places on the way home, but never on the way to work.

This is what my car is doing...

One more symptom is that the problem happens when I've let off of the gas pedal and I go to step back
down on it.

It will do a few "stumbles" or "hesitations", kind of like a jerky cut-out then it will be fine again.

Anyone have any ideas?

Thanks!
Scott
1991 Taurus/Sable does not use a DPFE Sensed EGR system, it use a PFE Sensed system which uses one hose off the EGR tube instead of two to check EGR pressure.
tbird100636 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome