EGR valve problem???? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-20-2012, 17:16 Thread Starter
Registered User
Join Date: Nov 2006
Posts: 240
EGR valve problem????

My ancient 99 Taurus (12 valve) sounds like a diesel! I also found a p0300 code which is for random multiple misfiring. I cleared that fault, it has not yet returned. I sure want to keep this old pal on the road, will not be able to afford another for some time.

I am not sure if there should ALWAYS be a vacuum on the vacuum line attached to the EGR. I did pull that hose and there was no vacuum present although that could be RPM related. I need help with that one----.

Now getting back to the EGR which I think could be my problem. Because I have not yet pull the valve off.....and I hope getting it off does not turn out to be a big deal, what should I look for? There are posts that reference cleaning the EGR but how do I do this? Of course, after I get the thing off that might be obvious.


foggysail is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-20-2012, 19:09
Dazed and Confused
CatSkinner's Avatar
Join Date: May 2012
Location: Upstate New York
Posts: 5,162
Re: EGR valve problem????

P0300 indicates misfire, I'd pull the plugs and inspect the wires. If they've got some time on them, might as well replace them.

The EGR, if the engine was running, yes, there should be vacuum. You might might want to replace your vacuum lines as well, including the bushing for the PCV. However, that low of a vacuum should throw a code as well. Best thing prior to getting too hairy with replacements, check running vacuum at idle.

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007

Quick Reply

Register Now

In order to be able to post messages on the Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome