Electrical Mystery - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-28-08, 08:04 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 2
Electrical Mystery

2004 Taurus Wagon. I parked my car and 1 hour later it was electrically dead. I opened the hood and tried to jump start it. When I turned on the key, it smoked from the alternator. I shut it down and got a tow. I replaced the alternator and the battery. The car started fine and I drove it around the block happy. Then I found the air conditioner did not work, the radio did not work and the brake/ABS light was on. I cannot find any blown fuses and it would be unusual if more than one fuse was blown. Any wild ideas?

nexus6 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-29-08, 05:04 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Electrical Mystery

Checked fusible links??
thefonz is offline  
post #3 of 5 (permalink) Old 07-29-08, 06:17 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 2
Re: Electrical Mystery

I cannot find any fuseable links in the schematics. Are there some on this car? It has the master fuse and some hefty fuses and relays. The schematic does not show anything COMMON to all of the problems but it is on digital media and only shows the sections.
nexus6 is offline  
post #4 of 5 (permalink) Old 07-30-08, 01:32 AM
NESHO SCT Tuner
 
Join Date: Mar 2003
Location: Illinois
Posts: 703
Re: Electrical Mystery

Ford has not used fuseable links since 1995.
SHOZ123 is offline  
post #5 of 5 (permalink) Old 07-30-08, 04:46 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Electrical Mystery

Quote:
Originally Posted by SHOZ123 View Post
Ford has not used fuseable links since 1995.
I guess I drive old crap. Didn't know they did away with the fusible links. Thanks for the info.
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome