high beams stuck on - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-21-06, 08:56 PM Thread Starter
Registered User
 
goattee34's Avatar
 
Join Date: Aug 2005
Location: Northern New York
Posts: 29
Question high beams stuck on

when i turn my car off, for some reason, my high beams will stay on. if i turn the headlights on, it will be fine, but if i turn the headlights off, the high beam symbol on the dash will light up, and i cant get them to turn off. any ideas on how to fix this problem? disconnecting the battery everytime i get out of the car is getting old quick. thanks

goattee34 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-24-06, 07:44 AM
NESHO SCT Tuner
 
Join Date: Mar 2003
Location: Illinois
Posts: 703
Re: high beams stuck on

If you have Daytime Running Lights I would guess the module is bad. It is made by Lucas of England you know.... :)
SHOZ123 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome