keep blowing #5 fuse on "93 SHO - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-29-2007, 20:25   #1 (permalink)
Registered User
 
Join Date: Apr 2007
Posts: 2
keep blowing #5 fuse on "93 SHO

if anyone has any answers let me know, have a short or something.
nine2nine is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-30-2007, 09:50   #2 (permalink)
Multi-Group Moderator
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 32
Posts: 1,826
Exclamation Re: keep blowing #5 fuse on "93 SHO

The 15A fuse #5 feeds the following circuits.
-The Rear defroster switch.
-The turn signal flasher.
-The back-up lamps.
-The heated O2 Sensors.
-The illuminated entry actuator.
-The electronic door lock control module.
-The brake/shift interlock solenoid.
__________________
Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline   Reply With Quote
Old 04-30-2007, 10:20   #3 (permalink)
Registered User
 
Join Date: Apr 2007
Posts: 2
Re: keep blowing #5 fuse on "93 SHO

i traced most of wires and unplugged everything i could, finally traced 2 wires ( the purple with orange that comes off that fuse) that went through firewall and found they went to o2 sensors, unplugged the front now fuse dont blow, plugged back in the o2 and still dont blow, now i am confused. i guess i will have to wait till it acts up again and try unplugging and see if that works.
nine2nine is offline   Reply With Quote
Old 05-17-2007, 06:32   #4 (permalink)
Registered User
 
Join Date: Apr 2007
Posts: 18
Re: keep blowing #5 fuse on "93 SHO

I'm having the same problem with my #8 fuse:(
troutdog is offline   Reply With Quote
Old 05-17-2007, 09:22   #5 (permalink)
Multi-Group Moderator
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 32
Posts: 1,826
Exclamation Re: keep blowing #5 fuse on "93 SHO

The 15A #8 fuse feeds the following circuits:
-Clock
-Radio Memory
-Glove box light
-Trunk light
-I/P courtesy lights
-Interior lights
-Illuminated entry actuator
-Electronic door lock control processor
-Power mirrors
__________________
Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:44.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.